Arithmetic Operators

Problem Statement

Let’s learn about Python’s arithmetic operators.

First, let’s read two integers:

a = int(raw_input())
b = int(raw_input())

Now, the three basic arithmetic operators are the following:

  • Addition (+)
  • Subtraction (-)
  • Multiplication (*)

(We’ll learn about division in the next task)

Task
Read two integers from STDIN and print three lines where:
(1) the first line contains the sum of the two numbers,
(2) the second line contains the difference of the two numbers (first – second),
(3) the third line contains the product of the two numbers.

Input Format
The first line contains the first integer, a, and the second line contains the second integer, b.

Constraints
1a1010
1b1010

Output Format
Print three lines as explained above.

Sample Input

3
2

Sample Output

5
1
6

Explanation
3+25
321
326

Solution

  
# Enter your code here. Read input from STDIN. Print output to STDOUT
a = int(raw_input())
b = int(raw_input())
print a+b
print a-b
print a*b

Raw Input

Problem Statement

Let’s look at Python’s input reading method.

>>> name = raw_input("Hey what's your name?\n")
Hey what's your name?
R2D2
>>> print name
R2D2

That’s one way of doing it for yourself. But in competitive programming we don’t ask questions. We only answer them. So we will only use raw_input() to read a string without asking any question to the system.

Task
Read a string from the console and print it.

Input Format
The first and only line of input contains a string.

Constraints
String length ≤ 500

Output Format
Print the same string back.

Sample Input

How many chickens does it take to cross the road?

Sample Output

How many chickens does it take to cross the road?

Solution

  
# Enter your code here. Read input from STDIN. Print output to STDOUT
print raw_input()


Hello World!

Problem Statement

Python is an interactive language that allows us to execute statements individually and see their results. In other words, you don’t have to write a full code and compile it before you execute to see the results as in other languages like C++ and Java.

Here is a sample line of code that can be executed in Python

print "Hello World!" 

You can even store the string in a variable and then print it:

my_string = "Hello World!"
print my_string

The above code will print Hello World! on your screen. You can try it in the console below.

P.S. Do try Solve Me First and Solve Me Second in Python before moving ahead.

Solution

  
#This is a single line comment
'''
This is 
a 
multiline comment
'''
#write your code in next line. 
my_string = "Hello World!"
print my_string

Solve me first FP

Problem Statement

This is an introductory challenge. The purpose of this challenge is to give you a working I/O template in your preferred language. It includes scanning 2 integers from STDIN, calling a function, returning a value, and printing it to STDOUT.

Your task is to scan two numbers from STDIN, and print the sum A+B on STDOUT.

Note: The code has been saved in a template, which you can submit if you want.

Input Format
Given A and B on two different lines.

Output Format
An integer that denotes Sum (A + B)

Constraints
1 ≤ A, B ≤ 1000

Sample Input

2
3

Sample Output

5

Solution : In Haskell

  
solveMeFirst a b = a + b

main = do
    val1 <- readLn
    val2 <- readLn
    let sum = solveMeFirst val1 val2
    print sum


Basic Data Types

Problem Statement

C++ has the following data types along with their format specifier:

  • Int (“%d”): 32 Bit integer
  • Long (%ld): 32 bit integer (same as Int for modern systems)
  • Long Long (“%lld”): 64 bit integer
  • Char (“%c”): Character type
  • Float (“%f”): 32 bit real value
  • Double (“%lf”): 64 bit real value

Reading
In order to read a data type, you need the following syntax:

scanf("`format_specifier`", &val)

E.g., in order to read a character and then a double

char ch;
double d;
scanf("%c %lf", &ch, &d);

P.S.: For the moment, we can ignore the spacing between format specifiers.


Printing
In order to print a data type, you need the following syntax:

printf("`format_specifier`", val)

E.g., in order to print a character and then a double

char ch = 'd';
double d = 234.432;
printf("%c %lf", ch, d);

P.S.: For the moment, we can ignore the spacing between format specifiers.

Input Format

Input will consists of an int, long, long long, char, float and double, each separated by a space.

Output Format

Print the elements in the same order, but each in a new line.

Sample Input

3 444 12345678912345 a 334.23 14049.30493

Sample Output

3
444
12345678912345
a
334.23
14049.30493

Solution

  
#include <iostream>
#include <cstdio>
using namespace std;

int main() {
    // Complete the code.
    int a;
    long b;
    char ch;
    long long c;
    float d;
    double f;    
    scanf("%d %ld %lld %c %f %lf  ", &a,&b,&c,&ch,&d,&f);
    printf("%d\n%ld\n%lld\n%c\n%f\n%lf",a,b,c,ch,d,f);
    return 0;
}